KISSlicer Overhang-Bug (All Versions + Stable Release)

Re: KISSlicer Overhang-Bug (All Versions + Stable Release)

Postby Beefi » 11 Oct 2019, 12:43

It's a Qidi X-Pro printer with a 32-Bit MCU.

Important: A cool parameter of 0.5 m³/s or even 0.001 m³/s doesn't have an effect to the fan and slow-down...every time (the same overhang) the fan will be set to S194...and the slowest slowdown is about 980 mm/min (16 mm/s) = 1.4 m³/s in my case.
The reason why there is no blob with Cool and Perimeter-flow the same, is because the normal fan-change is only at a destring and not in the middle of a perimeter.


I made some tests and screenshots...


Perimeters: 1.8 m³/s
Cool: 1.8 m³/s
There is NO Slow-down and NO M106 during the Perimeter.


SameFlow.PNG
SameFlow.PNG (49.08 KiB) Viewed 39 times

SameFlowCODE.PNG
SameFlowCODE.PNG (80.45 KiB) Viewed 39 times



Here is set the Cool Parameter to the value 1.7 m³/s:
Perimeter: 1.8 m³/s
Cool: 1.7 m³/s

NOTSameFlow_GCode.PNG
NOTSameFlow_GCode.PNG (80.69 KiB) Viewed 39 times
Beefi
 
Posts: 14
Joined: 07 Feb 2015, 07:00

Re: KISSlicer Overhang-Bug (All Versions + Stable Release)

Postby Beefi » 11 Oct 2019, 14:31

Hi,

I figured out some logic behind the overhang-feature:

The Cool-Flow-Setting has absolutely no effect on the printing speed of overhangs. The Cool-Flow setting has only effect on the fan-speed (M106-Command) at the overhang, and the max fan-speed for the overhang is dependent on the Loops-Fan-Speed setting.
The only setting which unfluences the overhang speed is the "Min Layer [s]" parameter...also it influences the slow-down and speed-up behaviour. Ok, but the min layer time parameter influences the overall speed. So this is no option.

There is another crazy behave...the Cooling-Fan-Speed for the overhangs is always lower than the normal Perimeter-Fan-Speed :?
So if you set the fan for loops to 60%, the overhang never has a fan of 60%...the fan is 10%, or 30% (dependent on Cool-Flow-Parameter).
...But especially a overhang needs more fan than a normal perimeter.

At the moment I can use this for workaround:
Setting Cool-Flow to a very high value (e.g. 100 m³/s) and set the the Loops-Fan to a good value for overhangs (e.g. 60%). So you have for Loops, Perimeters AND Overhangs the same fan-speed (in this case 60%) but also the same print-speed.
-> The Overhangfeature is quasi deactivated.

It would be nice for updates in future, that the Overhang-Speed is able to goes down to the Min-Flow-Setting. In my view the overhang feature isn't working right.
Whether you set a loop-fan of 5% or a loop-fan of 80%...the overhang will not be printed slower or faster (the Cool mm³/s parameter is not working right).
Beefi
 
Posts: 14
Joined: 07 Feb 2015, 07:00

Previous

Return to Alpha release talk

Who is online

Users browsing this forum: No registered users and 1 guest