Fails to save

Fails to save

Postby ensernet » 23 May 2018, 17:54

I open the same stl file that I used successfully several days ago. It slices ok but when I go to save it says Failed returns -1

Anyone have any idea whats going on
ensernet
 
Posts: 5
Joined: 20 Jun 2016, 15:47

Re: Fails to save

Postby pjr » 24 May 2018, 03:25

Open the Settings tab and navigate to Printer/Firmware. At the bottom of the window there is an entry field, "Post-Process". Is there anything in this field?

Peter
Please note: I do not have any affiliation with KISSlicer. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage or loss.
User avatar
pjr
 
Posts: 312
Joined: 05 May 2015, 10:27
Location: Slovenia

Re: Fails to save

Postby ensernet » 24 May 2018, 18:34

I don't see a settings tab in kisslicer. I am using rev 1.1.0.14
ensernet
 
Posts: 5
Joined: 20 Jun 2016, 15:47

Re: Fails to save

Postby pjr » 25 May 2018, 06:38

ensernet wrote:I don't see a settings tab in kisslicer. I am using rev 1.1.0.14


You really are missing out on the latest features of 1.63.

Peter
Please note: I do not have any affiliation with KISSlicer. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage or loss.
User avatar
pjr
 
Posts: 312
Joined: 05 May 2015, 10:27
Location: Slovenia

Re: Fails to save

Postby ensernet » 25 May 2018, 16:43

I have loaded 1.6.3 I get the same thing

Running the post process command:
cubeit.exe "c:\hand\bolt (1).bdf"
Failed, returning -1

it does output a file and it looks like good g codes but the printer says "unable to print file"

Any older file print fine
ensernet
 
Posts: 5
Joined: 20 Jun 2016, 15:47

Re: Fails to save

Postby ensernet » 25 May 2018, 17:02

I looked at some of my old .bfb file they had these 4 lines at the beginning of the file

^Firmware:V1.07
^Checksum: NO
^DRM:00000000
^Time:1

I added this to the files that didn't work on the printer and they worked How do I get those line add back into the file
ensernet
 
Posts: 5
Joined: 20 Jun 2016, 15:47

Re: Fails to save

Postby 3DBastler » 26 May 2018, 03:22

setting.jpg
setting.jpg (46.99 KiB) Viewed 238 times
As said, have a look at:
Profile Settings -> Printer -> Firmware -> Post-Process.
Should be a clear field.
3DBastler
 
Posts: 16
Joined: 09 Sep 2017, 05:23

Re: Fails to save

Postby pjr » 26 May 2018, 03:31

OK, so the question is: Do you want to run the post-processor?

If you do, it must be present in the specified location and you need to ensure that your post-processor command has double quotes where necessary.

Peter
Please note: I do not have any affiliation with KISSlicer. Any advices given are offered in good faith. It is your responsibility to ensure that by following my advice you do not suffer or cause injury, damage or loss.
User avatar
pjr
 
Posts: 312
Joined: 05 May 2015, 10:27
Location: Slovenia

Re: Fails to save

Postby ensernet » 26 May 2018, 07:32

Ok its slowly sinking in . I tried saving with nothing in the post-process window and the file save successfully but the file did not work on the printer

So I assume I need that post processing to get the right gcode format for the printer The line of text that was there was cubeit.exe "<file>" so I tried multiple variation to try to get the right format

like

"cubeit.exe"
C:\kisslicer\"cubeit.exe"
"c:\kisslicer\cubeit.exe"

none of these seemed to work the cubeit.exe file is present in the kisslicer dir.
ensernet
 
Posts: 5
Joined: 20 Jun 2016, 15:47

Re: Fails to save

Postby 3DBastler » 26 May 2018, 09:32

You may have a look here: (if not already done)
https://groups.google.com/forum/#!topic ... FOjYs747-k
does this possible help ahead?
3DBastler
 
Posts: 16
Joined: 09 Sep 2017, 05:23


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron